<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">

    <title>Marc Weller and Kevin Plank to Complete Port Covington Project - The News Hub</title>

<!-- This site is optimized with the Yoast SEO plugin v13.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In the fall of 2021, friends and business partners Mark Weller and Kevin Plank plan to open phase one of Baltimore&#039;s 235-acre Port Covington project."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Marc Weller and Kevin Plank to Complete Port Covington Project - The News Hub" />
<meta property="og:description" content="In the fall of 2021, friends and business partners Mark Weller and Kevin Plank plan to open phase one of Baltimore&#039;s 235-acre Port Covington project." />
<meta property="og:url" content="https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/" />
<meta property="og:site_name" content="The News Hub" />
<meta property="article:tag" content="kevin plank" />
<meta property="article:section" content="Business" />
<meta property="article:published_time" content="2020-03-20T19:55:07+00:00" />
<meta property="article:modified_time" content="2020-03-20T19:55:08+00:00" />
<meta property="og:updated_time" content="2020-03-20T19:55:08+00:00" />
<meta property="og:image" content="https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial.png" />
<meta property="og:image:secure_url" content="https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial.png" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="836" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="In the fall of 2021, friends and business partners Mark Weller and Kevin Plank plan to open phase one of Baltimore&#039;s 235-acre Port Covington project." />
<meta name="twitter:title" content="Marc Weller and Kevin Plank to Complete Port Covington Project - The News Hub" />
<meta name="twitter:image" content="https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.the-newshub.com/#website","url":"https://www.the-newshub.com/","name":"The News Hub","inLanguage":"en-US","description":"English language news you can use","potentialAction":[{"@type":"SearchAction","target":"https://www.the-newshub.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/#primaryimage","inLanguage":"en-US","url":"https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial.png","width":1600,"height":836},{"@type":"WebPage","@id":"https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/#webpage","url":"https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/","name":"Marc Weller and Kevin Plank to Complete Port Covington Project - The News Hub","isPartOf":{"@id":"https://www.the-newshub.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/#primaryimage"},"datePublished":"2020-03-20T19:55:07+00:00","dateModified":"2020-03-20T19:55:08+00:00","author":{"@id":"https://www.the-newshub.com/#/schema/person/b3416c15b2b34704b5b5924977d0459d"},"description":"In the fall of 2021, friends and business partners Mark Weller and Kevin Plank plan to open phase one of Baltimore's 235-acre Port Covington project.","potentialAction":[{"@type":"ReadAction","target":["https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/"]}]},{"@type":["Person"],"@id":"https://www.the-newshub.com/#/schema/person/b3416c15b2b34704b5b5924977d0459d","name":"Article Editor","image":{"@type":"ImageObject","@id":"https://www.the-newshub.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/9c1fa44b4ce9b801f2625450f951ea07?s=96&d=mm&r=g","caption":"Article Editor"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The News Hub &raquo; Feed" href="https://www.the-newshub.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The News Hub &raquo; Comments Feed" href="https://www.the-newshub.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.the-newshub.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.the-newshub.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='materialis-style-css'  href='https://www.the-newshub.com/wp-content/themes/materialis/style.min.css?ver=1.0.173' type='text/css' media='all' />
<style id='materialis-style-inline-css' type='text/css'>
img.logo.dark, img.custom-logo{width:auto;max-height:70px;}
</style>
<link rel='stylesheet' id='materialis-material-icons-css'  href='https://www.the-newshub.com/wp-content/themes/materialis/assets/css/material-icons.min.css?ver=1.0.173' type='text/css' media='all' />
<link rel='stylesheet' id='materialis-style-bundle-css'  href='https://www.the-newshub.com/wp-content/themes/materialis/assets/css/theme.bundle.min.css?ver=1.0.173' type='text/css' media='all' />
<link rel='stylesheet' id='materialis-fonts-css'   data-href='https://fonts.googleapis.com/css?family=Roboto:300,300italic,400,400italic,500,500italic,700,700italic,900,900italic%7CPlayfair%20Display:400,400italic,700,700italic&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='kirki-styles-materialis-css'  href='https://www.the-newshub.com/wp-content/themes/materialis/customizer/kirki/assets/css/kirki-styles.css' type='text/css' media='all' />
<style id='kirki-styles-materialis-inline-css' type='text/css'>
/** cached kirki style */.header-homepage{background-position:center bottom;}.header{background-position:center center;}.header-homepage.color-overlay:before{background:#181818;}.header-homepage .background-overlay,.header-homepage.color-overlay::before{opacity:0.4;}.header.color-overlay:before{background:#181818;}.header .background-overlay,.header.color-overlay::before{opacity:0.4;}.header-homepage .hero-title{color:#ffffff;}.header-homepage .header-description-row{padding-top:20%;padding-bottom:24%;}.inner-header-description{padding-top:10%;padding-bottom:10%;}@media (min-width: 768px){.materialis-front-page.overlap-first-section .header-homepage{padding-bottom:95px;}.materialis-front-page.overlap-first-section .page-content div[data-overlap]:first-of-type > div:not([class*="section-separator"]) {margin-top:-95px;}}@media screen and (max-width:767px){.header-homepage .header-description-row{padding-top:10%;padding-bottom:10%;}}@media only screen and (min-width: 768px){.header-content .align-holder{width:85%!important;}.inner-header-description{text-align:center!important;}}
</style>
<script type='text/javascript' src='https://www.the-newshub.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript'>
    
        (function ($) {
            function setHeaderTopSpacing() {
                $('.header-wrapper .header,.header-wrapper .header-homepage').css({
                    'padding-top': $('.header-top').height()
                });

             setTimeout(function() {
                  var headerTop = document.querySelector('.header-top');
                  var headers = document.querySelectorAll('.header-wrapper .header,.header-wrapper .header-homepage');

                  for (var i = 0; i < headers.length; i++) {
                      var item = headers[i];
                      item.style.paddingTop = headerTop.getBoundingClientRect().height + "px";
                  }

                    var languageSwitcher = document.querySelector('.materialis-language-switcher');

                    if(languageSwitcher){
                        languageSwitcher.style.top = "calc( " +  headerTop.getBoundingClientRect().height + "px + 1rem)" ;
                    }
                    
                }, 100);

            }

            jQuery(window).on('resize orientationchange', setHeaderTopSpacing);
            window.materialisSetHeaderTopSpacing = setHeaderTopSpacing

        })(jQuery);
    
    
MaterialisTheme = {"blog_posts_as_masonry_grid":true}
</script>
<script type='text/javascript' src='https://www.the-newshub.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.the-newshub.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.the-newshub.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.the-newshub.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.the-newshub.com/?p=570' />
<link rel="alternate" type="application/json+oembed" href="https://www.the-newshub.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.the-newshub.com%2Fmarc-weller-and-kevin-plank-to-complete-port-covington-project%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.the-newshub.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.the-newshub.com%2Fmarc-weller-and-kevin-plank-to-complete-port-covington-project%2F&#038;format=xml" />

		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-42680213-71', 'auto');
			ga('send', 'pageview');
		</script>

	    <script type="text/javascript" data-name="async-styles">
        (function () {
            var links = document.querySelectorAll('link[data-href]');
            for (var i = 0; i < links.length; i++) {
                var item = links[i];
                item.href = item.getAttribute('data-href')
            }
        })();
    </script>
    <style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>    <style id="page-content-custom-styles">
            </style>
        <style data-name="background-content-colors">
        .materialis-front-page .content.blog-page,
        .materialis-inner-page .page-content,
        .materialis-inner-page .content,
        .materialis-front-page.materialis-content-padding .page-content {
            background-color: #f5fafd;
        }
    </style>
    </head>

<body class="post-template-default single single-post postid-570 single-format-standard overlap-first-section materialis-inner-page">
    <style>
        .screen-reader-text[href="#page-content"]:focus {
            background-color: #f1f1f1;
            border-radius: 3px;
            box-shadow: 0 0 2px 2px rgba(0, 0, 0, 0.6);
            clip: auto !important;
            clip-path: none;
            color: #21759b;
           
        }
    </style>
    <a class="skip-link screen-reader-text" href="#page-content">Skip to content</a>
    <div id="page-top" class="header-top">
            <div class="header-top-bar ">
            <div class="">
                <div class="header-top-bar-inner row middle-xs start-xs ">
                        <div class="header-top-bar-area  col-xs area-left">
                <div class="top-bar-field" data-type="group"  data-dynamic-mod="true">
            <i class="mdi mdi-pin"></i>
            <span>Location,UT 84097,USA</span>
        </div>
                <div class="top-bar-field" data-type="group"  data-dynamic-mod="true">
            <i class="mdi mdi-cellphone-android"></i>
            <span>+18012240098</span>
        </div>
                <div class="top-bar-field" data-type="group"  data-dynamic-mod="true">
            <i class="mdi mdi-email"></i>
            <span>info@the-newshub.com</span>
        </div>
            </div>
                            <div class="header-top-bar-area  col-xs-fit area-right">
            <div data-type="group"  data-dynamic-mod="true" class="top-bar-social-icons">
                      <a target="_blank"  class="social-icon" href="https://twitter.com/thenewshub">
                  <i class="mdi mdi-twitter-box"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="https://www.linkedin.com/company/the-news-hub/about/">
                  <i class="mdi mdi-account-card-details"></i>
              </a>
              
    </div>

        </div>
                    </div>
            </div>
        </div>
            <div class="navigation-bar  "  data-sticky='0'  data-sticky-mobile='1'  data-sticky-to='top' >
    <div class="navigation-wrapper">
        <div class="row basis-auto">
            <div class="logo_col col-xs col-sm-fit">
                <a class="text-logo" data-type="group"  data-dynamic-mod="true" href="https://www.the-newshub.com/">The<span style="font-weight: 300;" class="span12"> News</span> Hub</a>            </div>
            <div class="main_menu_col col-xs">
                <div id="mainmenu_container" class="simple-text-buttons main-menu dropdown-menu row"><ul id="main_menu" class="simple-text-buttons main-menu dropdown-menu"><li class="page_item page-item-6 current_page_parent"><a href="https://www.the-newshub.com/blog/">Blog</a></li><li class="page_item page-item-19"><a href="https://www.the-newshub.com/contact/">Contact</a></li><li class="page_item page-item-5"><a href="https://www.the-newshub.com/">Home</a></li><li class="page_item page-item-3"><a href="https://www.the-newshub.com/privacy-policy/">Privacy Policy</a></li></ul></div>    <a href="#" data-component="offcanvas" data-target="#offcanvas-wrapper" data-direction="right" data-width="300px" data-push="false">
        <div class="bubble"></div>
        <i class="mdi mdi-view-sequential"></i>
    </a>
    <div id="offcanvas-wrapper" class="hide force-hide offcanvas-right">
        <div class="offcanvas-top">
            <div class="logo-holder">
                <a class="text-logo" data-type="group"  data-dynamic-mod="true" href="https://www.the-newshub.com/">The<span style="font-weight: 300;" class="span12"> News</span> Hub</a>            </div>
        </div>
        <div id="offcanvas_menu" class="offcanvas_menu"><ul id="offcanvas_menu" class="offcanvas_menu"><li class="page_item page-item-6 current_page_parent"><a href="https://www.the-newshub.com/blog/">Blog</a></li><li class="page_item page-item-19"><a href="https://www.the-newshub.com/contact/">Contact</a></li><li class="page_item page-item-5"><a href="https://www.the-newshub.com/">Home</a></li><li class="page_item page-item-3"><a href="https://www.the-newshub.com/privacy-policy/">Privacy Policy</a></li></ul></div>
            </div>
                </div>
        </div>
    </div>
</div>
</div>

<div id="page" class="site">
    <div class="header-wrapper">
        <div  class='header  color-overlay  custom-mobile-image' style='; background-image:url(&quot;https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial.png&quot;); background-color:#6a73da'>
                                        <div class="inner-header-description gridContainer">
        <div class="row header-description-row">
            <div class="col-xs col-xs-12">
                <h1 class="hero-title">
                    Marc Weller and Kevin Plank to Complete Port Covington Project                </h1>
                                    <p class="header-subtitle">English language news you can use</p>
                            </div>

        </div>
    </div>
        <script>
        window.materialisSetHeaderTopSpacing();
    </script>
                        </div>
    </div>
<div  class='content post-page' style='' id='page-content'>
    <div class="gridContainer">
        <div class="row">
            <div class=" col-sm-8 col-md-9">
                <div class="post-item">
                    <div id="post-570"class="post-570 post type-post status-publish format-standard has-post-thumbnail hentry category-business tag-kevin-plank">

    <div class="post-content-single mdc-card">

        <div class="post-content-inner">

            <img width="1232" height="644" src="https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial-1232x644.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial-1232x644.png 1232w, https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial-300x157.png 300w, https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial-1024x535.png 1024w, https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial-768x401.png 768w, https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial-1536x803.png 1536w, https://www.the-newshub.com/wp-content/uploads/2020/03/PC_LargeGallery-01-Aerial.png 1600w" sizes="(max-width: 1232px) 100vw, 1232px" />            <div class="col-padding">
                <h3>Marc Weller and Kevin Plank to Complete Port Covington Project</h3>                <p><div class="gridContainer"></p>
<p>Marc Weller,<br />
the founder and president of Weller Development Co., was only 15 years old when<br />
he started his own landscaping business. In exchange for work he did for his<br />
father, his father bought him the equipment he needed to&nbsp;attract clients.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>Weller<br />
recalls the immense satisfaction he felt when he completed his first big<br />
mulching job along with the help of a friend in which they planted large beds<br />
of geraniums. He remembers being dirty and sweaty, and surveying his<br />
achievement at the end of the day. He thought to himself, “How cool to see what<br />
we accomplished — and to think, we actually got paid for it!”</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>That feeling<br />
of accomplishment stayed with Weller, and he transferred it to real estate<br />
development.&nbsp;For more than 25 years, he built apartment buildings<br />
and&nbsp;single-family homes. Instead of completing a project in one day, he<br />
now may wait five to 10 years for a project to be completed, and although the<br />
result is much greater than planting geraniums, he still has that same great<br />
sense of satisfaction.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>He has<br />
always remained true to his core principle: He believes that if you do great<br />
work and create a good product, the money will come. His goal is to make things<br />
better than they were when he first saw them.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>Baltimore residents are likely familiar with Weller’s current endeavor: the <a href="https://archpaper.com/2018/09/baltimore-port-covington/">Port Covington development project</a>. Chapter 1 of the 235-acre real estate development will be built on 12 city blocks and include 1.38 million square feet of office space, nearly 340,000 square feet of retail space, and nearly 1 million square feet of residential space, with 285,000 square feet designated for hotel space. It is scheduled to open in the fall of 2021.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<h3><strong>Marc Weller and Kevin Plank: Developers of the Port<br />
Covington Project</strong></h3>
<p></div></p>
<p><div class="gridContainer"></p>
<p>Weller is joined in the Port Covington Project with his long-time friend, Kevin Plank, <a href="https://www.fundable.com/learn/startup-stories/under-armour">owner and founder of Under Armour</a>, maker of moisture-wicking T-shirts. Plank started Under Armour in his grandmother’s basement and it has grown to be, according to Forbes Magazine, “the largest digital health and fitness company on Earth.”</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>So, how did<br />
two highly successful businessmen, a T-shirt manufacturer and real estate<br />
developer, come to work together on the Port Covington project? Perhaps<br />
serendipity was a contributing factor.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>When Weller was in high school, one of his good friends was Bill McDermond (Billy Mac), who later became an early Under Armour executive. When Billy Mac went to college, he became good friends with <a href="https://medium.com/@kevinplank">Kevin Plank</a>. Billy Mac introduced his two good friends to each other. Weller and Plank stayed in touch from then on, seeing each other sporadically at social events. During the ensuing years, each man became a successful businessman in his own right.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>In 2012, <a href="https://www.bizjournals.com/baltimore/news/2020/02/28/podcast-marc-weller-on-how-he-met-kevin-plank-took.html">Plank called Weller</a> and invited him to meet at Plank’s office in Baltimore. They talked about how to develop projects that would make the city a better place for residents and employers, and also how to help create jobs.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>It was<br />
exactly the type of project Weller had always wanted to do. He says, “I was<br />
completely sold. I wanted to sign up immediately.”</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>The two men<br />
became partners in Sagamore Development Company with a handshake. In the summer<br />
of 2016, they unveiled their plans for Port Covington. The project involves<br />
transforming 45 city blocks. Weller noted that planning for a project of this<br />
size must be “thoughtful” since it really amounts to a city annex.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>The partners<br />
put the entire plan together before inviting in investors. When attracting<br />
investors, they focused on what is already good about Baltimore, and not<br />
“celebrating” what is wrong. The new development company excited potential<br />
investors by introducing them to the incredible food scene and world-class<br />
hotels. They took them on a water taxi tour and inspired them with the<br />
opportunity of&nbsp;creating jobs. &nbsp;&nbsp;</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>In September<br />
2017, Goldman Sachs Urban Investment Group invested $233 million in the project<br />
as well as a $660 million tax increment financing (TIF) package. The TIF was<br />
approved by the Baltimore City Council to fund the project’s infrastructure,<br />
including building of roads.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>In the<br />
summer of 2019, ground was broken for the Port Covington project Chapter 1. The<br />
company was incredibly fortunate with how quickly it was able to complete the<br />
horizontal construction, such as the roads, water, and sewer. They had five<br />
straight months with almost no rain, which allowed them to complete that potion<br />
of the project ahead of schedule.</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>Building is<br />
now in the vertical stage with the plans focused on quality buildings that are<br />
not too tall and not too big. Weller says, “We are building on a human scale.<br />
We can go up later if we need to.”</p>
<p></div></p>
<p><div class="gridContainer"></p>
<p>The streets<br />
will be curb-free in order to accommodate festivals and parades. A significant<br />
amount of money is going into landscaping, with planting designed to provide<br />
shade. The goal is to have a combination of buildings, landscape, and open<br />
space that will set the project apart, but still be very Baltimore. Today’s<br />
user will feel a sense of genuine comfort that will make them “want to come<br />
down there and spend time.”</p>
<p></div></p>
                <p class="tags-list"><i data-cp-mdi="true" class="font-icon-25 fa fa-tags"></i>&nbsp;<a href="https://www.the-newshub.com/tag/kevin-plank/" rel="tag">kevin plank</a></p>            </div>
        </div>
        
<div class="post-meta mdc-card__actions col-padding">
    <div class="mdc-card__action-icons col-xs-12 col-sm-fit">
        <a class="post-footer-link" href="https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/">
            <i class="mdi small mdi-comment-outline mdc-card__action mdc-card__action--icon" title="Comments"></i>
            <span class="post-footer-value">0</span>
        </a>
        <a class="post-footer-link" href="https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/">
            <i class="mdi small mdi-clock mdc-card__action mdc-card__action--icon" title="Post Time"></i>
            <span class="post-footer-value">March 20, 2020</span>
        </a>
                        <div class="post-footer-category">
                    <i class="mdi small mdi-folder-open mdc-card__action mdc-card__action--icon" title="Categories"></i>
                    <a href="https://www.the-newshub.com/category/business/"  class="button color5 link small">Business</a>                </div>
                    </div>

</div>
    </div>


    
    
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.the-newshub.com/free-vps-panels-how-to-choose-the-best-for-you/" rel="prev"><i class="font-icon-post mdi mdi-chevron-left"></i><span class="meta-nav" aria-hidden="true">Previous:</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Previous Post</span></a></div></div>
	</nav>

</div>
                </div>
            </div>
            

<div class="sidebar col-sm-4 col-md-3">
    <div class="sidebar-row">
            </div>
    <div class="sidebar-row">
        <div id="search-2" class="widget widget_search mdc-elevation--z5"><form role="search" method="get" class="search-form" action="https://www.the-newshub.com/">
    <div class="mdc-text-field">
		<input  type="text" id="s" class="search-field mdc-text-field__input" name="s" value="">
        <label class="mdc-floating-label" for="s">Search for:</label>
        <div class="mdc-line-ripple"></div>
    </div>
</form>
</div>		<div id="recent-posts-2" class="widget widget_recent_entries mdc-elevation--z5">		<h5 class="widgettitle"><i class="mdi widget-icon"></i>Recent Posts</h5>		<ul>
											<li>
					<a href="https://www.the-newshub.com/marc-weller-and-kevin-plank-to-complete-port-covington-project/" aria-current="page">Marc Weller and Kevin Plank to Complete Port Covington Project</a>
									</li>
											<li>
					<a href="https://www.the-newshub.com/free-vps-panels-how-to-choose-the-best-for-you/">(no title)</a>
									</li>
											<li>
					<a href="https://www.the-newshub.com/james-river-capital-navigates-company-crisis/">How James River Capital Successfully Navigates A Company Crisis</a>
									</li>
											<li>
					<a href="https://www.the-newshub.com/superyacht-sales-are-on-the-rise-heres-why/">Superyacht Sales are on the Rise – Here’s Why</a>
									</li>
											<li>
					<a href="https://www.the-newshub.com/what-should-you-do-if-youre-arrested/">What Should You Do If You’re Arrested?</a>
									</li>
					</ul>
		</div><div id="recent-comments-2" class="widget widget_recent_comments mdc-elevation--z5"><h5 class="widgettitle"><i class="mdi widget-icon"></i>Recent Comments</h5><ul id="recentcomments"></ul></div><div id="archives-2" class="widget widget_archive mdc-elevation--z5"><h5 class="widgettitle"><i class="mdi widget-icon"></i>Archives</h5>		<ul>
				<li><a href='https://www.the-newshub.com/2020/03/'>March 2020</a></li>
	<li><a href='https://www.the-newshub.com/2020/02/'>February 2020</a></li>
	<li><a href='https://www.the-newshub.com/2020/01/'>January 2020</a></li>
	<li><a href='https://www.the-newshub.com/2019/12/'>December 2019</a></li>
	<li><a href='https://www.the-newshub.com/2019/11/'>November 2019</a></li>
	<li><a href='https://www.the-newshub.com/2019/10/'>October 2019</a></li>
	<li><a href='https://www.the-newshub.com/2019/03/'>March 2019</a></li>
	<li><a href='https://www.the-newshub.com/2019/01/'>January 2019</a></li>
		</ul>
			</div><div id="categories-2" class="widget widget_categories mdc-elevation--z5"><h5 class="widgettitle"><i class="mdi widget-icon"></i>Categories</h5>		<ul>
				<li class="cat-item cat-item-4"><a href="https://www.the-newshub.com/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://www.the-newshub.com/category/finance/">Finance</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://www.the-newshub.com/category/health/">Health</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://www.the-newshub.com/category/news/">News</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://www.the-newshub.com/category/tech/">Tech</a>
</li>
		</ul>
			</div><div id="meta-2" class="widget widget_meta mdc-elevation--z5"><h5 class="widgettitle"><i class="mdi widget-icon"></i>Meta</h5>			<ul>
						<li><a rel="nofollow" href="https://www.the-newshub.com/wp-login.php">Log in</a></li>
			<li><a href="https://www.the-newshub.com/feed/">Entries feed</a></li>
			<li><a href="https://www.the-newshub.com/comments/feed/">Comments feed</a></li>
			<li><a href="https://wordpress.org/">WordPress.org</a></li>			</ul>
			</div>    </div>

</div>
        </div>
    </div>

</div>
<div  class='footer footer-simple'>
    <div  class='footer-content center-xs'>
        <div class="gridContainer">
	        <div class="row middle-xs footer-content-row">
	            <div class="footer-content-col col-xs-12">
	                    <p  class="copyright">&copy;&nbsp;&nbsp;2020&nbsp;The News Hub.&nbsp;Built using WordPress and the <a target="_blank" href="https://extendthemes.com/go/built-with-materialis/">Materialis Theme</a></p>	            </div>
	        </div>
	    </div>
    </div>
</div>
<script type='text/javascript' src='https://www.the-newshub.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.the-newshub.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript'  defer="defer" src='https://www.the-newshub.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'  defer="defer" src='https://www.the-newshub.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'  defer="defer" src='https://www.the-newshub.com/wp-content/themes/materialis/assets/js/theme.bundle.min.js?ver=1.0.173'></script>
<script type='text/javascript'  defer="defer" src='https://www.the-newshub.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
    <script>
        /(trident|msie)/i.test(navigator.userAgent) && document.getElementById && window.addEventListener && window.addEventListener("hashchange", function() {
            var t, e = location.hash.substring(1);
            /^[A-z0-9_-]+$/.test(e) && (t = document.getElementById(e)) && (/^(?:a|select|input|button|textarea)$/i.test(t.tagName) || (t.tabIndex = -1), t.focus())
        }, !1);
    </script>
</body>
</html>
